Form not displaying message after submit

Permalink
The form on my site is not displaying the message after the user presses submit. The message is set up in the options tab. Can anyone help with this?

I am using the form block.

What happens is that the form resets itself and goes blank. As a result the client keeps getting people who are submitting the form multiple times because they think something is wrong.

https://glimmerglass.org/index.php/contact-us/...

site is up to date with the latest C5 version.

wanderlust
View Replies:
ryan replied on at Permalink Reply 1 Attachment
ryan
Check to make sure that you don't have a page selected (in that same options tab) to redirect to after form submission.
wanderlust replied on at Permalink Reply
wanderlust
there is no page selected. any other ideas?
Kurieuo replied on at Permalink Reply
I'm getting this too.

At least, the validation error message shows.

But on a successful submit, the success message doesn't show.

It too is not configured to go to a different page.
dpejenck replied on at Permalink Reply
dpejenck
I have a similar issue. The Thanks message displays when I am signed in and editing my site but fails to display after I sign out.

I will use a Thank you page for now...
drbiskit replied on at Permalink Reply
drbiskit
Did you ever find a fix for this at all? I have the same issue.
jaqueline replied on at Permalink Reply
I have the same problem.
does anyone have a solution?
drbiskit replied on at Permalink Reply
drbiskit
I honestly can't remember quite what I did to get around this issue.

I have been using Jordan Lev's custom form templates quite a lot recently and they work really well - maybe try applying this one to your site and see if it fixes the issue:

https://github.com/jordanlev/c5_ajax_form...

Installation instructions are on the github page.