Turned cache off completely - now site much faster!

Permalink
Strange but true, I've been experiencing problems with a site I'm developing and tried a variety of things to get the site to load more quickly, all to no avail. In a fit of frustration I tried turning off all the cache in 'systems & settings'. Now the site runs much faster.

Previous tests revealed page load times took upto twenty seconds, sometimes not loading at all. Now most of the pages load upto five times faster, loading in aprox 4 or 5 seconds.

So what gives? (as the Americans would say) Surely the cache functionality in the cms should make the site run more quickly?

Has anyone else expeienced this?

View Replies:
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
As you told "Previous tests revealed page load times took upto twenty seconds, sometimes not loading at all."
It seems like the problem was in hosting as sometime it doesn't load. But now you can try to put the caching on & check whether it makes your site more faster.

Rony
kappi replied on at Permalink Reply
Hello Rony,

I haved already spoken to the hosting company (Heart Internet) and they say there are no problems.

I've tried a variety of the cache settings and the best one appears to be turn the cache off.

Anyway thanks for the input, much appreciated
ryan replied on at Permalink Reply
ryan
What version of concrete5 were you working with? The caching is built very differently in 5.6+. In older versions the cache was very disk io intensive, so it would speed up a site until the io was saturated.
TheRealSean replied on at Permalink Reply
TheRealSean
Also try the following in your .htaccess file,

If supported I find these can help speed up your site, sets server side caching and compression
IfModule mod_deflate.c>
 # compress text, html, javascript, css, xml:
 AddOutputFilterByType DEFLATE text/plain
 AddOutputFilterByType DEFLATE text/html
 AddOutputFilterByType DEFLATE text/xml
 AddOutputFilterByType DEFLATE text/css
 AddOutputFilterByType DEFLATE application/xml
 AddOutputFilterByType DEFLATE application/xhtml+xml
 AddOutputFilterByType DEFLATE application/rss+xml
 AddOutputFilterByType DEFLATE application/javascript
 AddOutputFilterByType DEFLATE application/x-javascript
 <Files ~ "^[^\.]+$">
 ForceType application/x-httpd-php
 SetOutputFilter DEFLATE
 </Files>
mhawke replied on at Permalink Reply
mhawke
Cloudflare or other 'cloud' caching schemes can also mess with the built-in C5 caching scheme so I turn all those 'features' off in the Control Panel. My guess is that it's a v5.5.2 site that needs to be upgraded to v5.6.1.2