Concrete5 Version 8 Won't Upgrade or Fresh Install

I cannot get Version 8 to install at all.

First, I installed Then I manually downloaded 5-8.1.0 and followed the instructions for a Manual Dashboard Update (found When I went to the dashboard under Update Concrete5, no update was found.

Next, I tried "Upgrading via the command line". When I got to the step to run the command, "concrete/bin/concrete5 c5:update", it said "c5:update" command not found.

Last, I tried a straight up manual install -- no updating, using the instructions here (I note these are for 5.7, but I cannot find any different instructions for Version 8 in the docs). After I created the database and put the files in place, I visited the site (step 6) and filled in all the requested information. The install has been sitting there spinning for over an hour. I've checked the database and ZERO tables have been created. It's empty.

Is version 8 just that immature? Would I be better sticking with 5.7?

Any help would be appreciated. Thanks.

View Replies: View Best Answer
ltinnel replied on at Permalink Best Answer Reply 3 Attachments
I was able to do a fresh install from the command line, but not from visiting the web site. Not sure why. BUT. When installing from the command line, the Members function is broken. I'm attaching what I see when I click on Members and the results if I do a search, which I'm fairly confident isn't supposed to happen. Also, the advanced search dialogue appears... broken.

The file upload is similarly broken. I would expect when clicking on Files would show me the files, as 5.7 did, even if a different format.
ltinnel replied on at Permalink Reply
I finally gave up and installed, which works great. Perhaps I'll try Version 8 again in the future, when it works properly.
lecomm replied on at Permalink Reply
I'm also getting an error trying to upgrade from to 8.1.0 by replacing the /concrete directory or putting the new version into /updates folder as recomended in the upgrade documentation.
Both ways i'm getting
include(<PATH DELETED>/concrete/vendor/composer/../doctrine/migrations/lib/Doctrine/DBAL/Migrations/Finder/MigrationDeepFinderInterface.php): failed to open stream: No such file or directory

I checked the file /concrete/vendor/doctrine/migrations/lib/Doctrine/DBAL/Migrations/Finder/MigrationDeepFinderInterface.php, which seems to exist. What is wrong?
serot0nin replied on at Permalink Reply
I tried a fresh install of 8.1.0 and two errors came up in the console:
install:73 Uncaught ReferenceError: NProgress is not defined
Failed to load resource: the server responded with a status of 404 (Not Found)

Previously, I've used a successful install 8.0.3 (fresh) on another project, which I then upgraded to 8.1.0.

For now, I'm going to install 8.0.3 first, then upgrade to 8.1.0.

PS: using Chrome 56.0.2924.87 on MacOS Sierra
serot0nin replied on at Permalink Reply
Oddly, I've just done a fresh install of 8.1.0 on my local machine (under MAMP on MacOS Sierra) and all appears to have gone well.
nthorpe replied on at Permalink Reply
Just tried a clean install of 8.1.0 using Chrome as the browser and got the

NProgress is not defined

message in the console.

I then went to the index.php/install page in Firefox and the install continued right through to successful completion without any further input from me.
jjdb210 replied on at Permalink Reply
I just attempted to do a semi-fresh install of 8.1, and like other people in the thread, I also got the "NProgress is not defined" in my console. That said, I did a hard reload in chrome of the install page, and magically it went. I did have an older version of concrete5 installed on this address, so I'm guessing that perhaps something changed in Jquery that was cached locally that didn't allow the install until I did a cache clear.
SeanDevoy replied on at Permalink Reply
I have been getting this error trying 8.1 to 8.4.2 on my local system. After seeing nthorpe's post I cleared the CHROME cache and tried again. Everything worked fine.

Thanks nthorpe.