Database should support the configured character set and collation - ERROR

Permalink
Hi Folks,
Please help.
While installing, I get this warning:

"Database should support the configured character set and collation
The database does not have a complete support for all the Unicode characters. This implies, for example, that you may not be able to save emoticons (it's the same behavior as concrete5 versions older than 8.5.0). You should upgrade your database to fix this issue. "

Shared host
My PHP version: 7.3.6
MySQL version: 5.6.47

thanks in anticipation.
Aladin

View Replies:
JohntheFish replied on at Permalink Reply
JohntheFish
Is this a localhost install, where you have control over the database versions etc, or a server install - and if so, do you have admin access to the server?
aladincomadin replied on at Permalink Reply
It is not localhost, I am on a shared hosting server.
I have no admin access to versions
JohntheFish replied on at Permalink Reply
JohntheFish
Shared hosting environments generally provide a management interface such as cPanel where you can create a database. When you create that database, it needs to be given the character set UTF8 MB4 and collation utf8mb4_general_ci

Nevertheless, what you are seeing is only a warning, not a fatal issue. So if you wanted to proceed on your current database, you would have a viable site, but it may be limited in some capabilities such as multilingual, and as the warning notes, use of emojis.
aladincomadin replied on at Permalink Reply 3 Attachments
Dear JohntheFish,
Thanks for the reply.
I have already set "UTF8 MB4 and collation utf8mb4_general_ci" using.

When installing ignoring the warning database get created. But install does not get completed, I get this error.

{"error":true,"message":"There are already 273 tables in this database. concrete5 must be installed in an empty database.


It is on freshly made empty database.

I have attached screenshots in each 3 steps.
JohntheFish replied on at Permalink Reply
JohntheFish
In the server admin panel, you need to delete all tables in the database before you can try again. c5 will only install into a database that contains absolutely no existing tables.
aladincomadin replied on at Permalink Reply
Thanks for the reply.
There was none to delete on a fresh DB.

I tried installing after deleting the DB and creating new one many times at least a dozen times. No luck. I think it is a bug in the installer.
Any experienced developers, please lend a hand.
aladincomadin replied on at Permalink Reply
any one please help
Gondwana replied on at Permalink Reply
Gondwana
You have rejected the right answer.
aladincomadin replied on at Permalink Reply
Which one?
Gondwana replied on at Permalink Reply
Gondwana
That of JohnTheFish, who is an exceptionally experienced developer.

You need to drop all tables from the database before retrying with it, or drop the whole database and recreate it.
Gondwana replied on at Permalink Reply
Gondwana
I have heard it said that the database SERVER (eg, mysql/mariadb) installation may need to be updated to make the database collation warning go away.
aladincomadin replied on at Permalink Reply
After creating database I change the collocation to utf8mb4
aladincomadin replied on at Permalink Reply 1 Attachment
I tried to install at least 12 times. Every time on a fresh database created in a new name. I delete the old ones to save space on server. I have Drupal Sites running on the same server since 2010

First installation itself fails.
I have attached the message I am getting once again

Anyone please help.
stewblack23 replied on at Permalink Reply
stewblack23
I would trying changing your PHP version down to 7.2. or 7.1. Sometimes 7.3 acts weird for me on new C5 installs. Also test to make sure you can install the C5 on a localhost and test multiple PHP version for errors.

Also make sure under advanced options you have the correct timezone selected where the server resides.

Are you still getting character set warning?
aladincomadin replied on at Permalink Reply
I still get character warning. Time zone is correct

Changed the PHP version to 7.1 same error with slight difference

{"error":true,"message":"There are already 198 tables in this database. concrete5 must be installed in an empty database..\u003Cbr\u003E\u003Cbr\u003ETrace:\u003Cbr\u003E#0 \/home\/sherifma\/public_html\/stunfun.com\/concrete\/src\/Package\/StartingPointPackage.php(186): Concrete\\Core\\Package\\StartingPointPackage-\u003Einstall_database()\n#1 \/home\/sherifma\/public_html\/stunfun.com\/concrete\/controllers\/install.php(398): Concrete\\Core\\Package\\StartingPointPackage-\u003EexecuteInstallRoutine(\u0027install_databas...\u0027)\n#2 [internal function]: Concrete\\Controller\\Install-\u003Erun_routine(\u0027elemental_full\u0027, ......
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
How long does the install run before it throws the error?
aladincomadin replied on at Permalink Reply
Approximately 5 minutes. The last install was 8.5.1, not 8.5.2.
Both give no luck
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Probably you are suffering from a slow server that is timing out before the installation has finished.
See if you can get your server admin to increase the resources, e.g. increase the php timeout setting and the amount of ram allocated to your server.
aladincomadin replied on at Permalink Reply
thanks