Migrating developments site to Live Server.

Interesting problem.

We have a site that is completed (using Clonemental Theme). On my development laptop everything is fine, all the pages and content is available.

About 3 weeks ago, we put the site into production. All was well. Last week, the client wanted some additional features and work done. We did this on my development laptop.

We have those requests complete so time to move to Production. Cleared cache (laptop and production), backed up Production (root folder and DB).

I cleared cache on my laptop (as per standard requirements), dumped the mysql db, stopped the local web server and copied everything up to a production server.

Imported the DB, exploded the html folder accordingly.

When I connect to the production server, the content changes are NOT there, two new pages are not there as well.

I checked the DB on the production server and can see the content we added, but nothing new shows up.

Backed up everything on my laptop, brought the site back down from production and it's fine.

Redid the migration to production (after cleaning up etc.), still nothing new. We have done this many times and never had this issue.

I'm sure it's a "me thing"...

Hopefully someone can tell me what have I forgot?

ConcreteOwl replied on at Permalink Reply
check the server is not running a backend cache, something like cachewall or lightspeed cache.
barbedwire replied on at Permalink Reply
Tx for this. I should have mentioned that we are not running any backend caching.

Still perplexed. The original site is still online so we’re not damaged. Just confused as to why.

Seriously, we have performed the exact same steps dozens of times.

We’ve tried several times today to no avail, at the end of the day, we’re gonna put it on another server.

Tx again.
barbedwire replied on at Permalink Reply
I think there is a problem with clearing cache.

When migrating a site to a new server, clearing cache does not seem to delete the files in the cache folder...

We tried this on 3 sites, same thing. If I manually delete the cache the migrate/move works fine.

I don’t think this to be a file security issue as files do get cached.

Any thoughts as to why the cache does not actually get cleared.