Pretty urls and Fatcow

Permalink
Has anyone else had trouble with enabling pretty urls and Fatcow hosting? I am using v5.4.0.5 and when I enable them and add the code to the .htaccess file in the concrete root, I get a white page saying "no input file specified." I have another site running on Bluehost that works fine. the only other difference between the two is on this one the concrete files are not in root, they are in concrete5.3.3.1 folder.

Thanks.

sceva
View Replies:
Mnkras replied on at Permalink Reply
Mnkras
sceva replied on at Permalink Reply
sceva
I didn't have any luck with that. I will try again next week and let you know.
iLP replied on at Permalink Reply
iLP
Nothing I tried would work on fatcow hosting, until I stumbled upon this is in a buried thread:

"The problem with your rewrites is that apache thinks "index.php/foo/bar" is supposed to be a file, but of course it isn't :)
I'd suggest trying either

RewriteRule ^(.+)$ index.php?/$1


or

RewriteRule ^(.+)$ index.php/$1 [R]


Note the question mark in rule 1 and the new R flag in rule 2."