pretty urls are broken

Hi, I am looking for some guidance on what to do for an older version of Concrete5. We recently noticed the pretty urls are broken on the site. Going to the domain shows the "under construction" concrete5 page. Adding ...index.php to the url shows the correct page. I tried turning off pretty urls, clearing the cache, and refreshing, but it did not help.

I also tried updating PHP to 7.0, 7.1, and 7.2 but each of those caused the whole site to go down.

The website is still on http.

Any tips on the best way to resolve this or update things so they work are appreciated. Thanks.

Some details:
The site is hosted on Bluehost, and I think I used Simplescripts to set up the Concrete5 site, and I can't log into SimpleScripts on cpanel, so I am not sure that is available any longer.
# concrete5 Version

# concrete5 Packages
AddThis (1.0), Galleria image gallery (2.0), Sortable Fancybox Gallery (1.14).

# concrete5 Overrides
blocks/autonav, jobs/index_search.php, libraries/database_indexed_search_old.php, themes/avatheme, themes/earthtones_water

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off

# Server Software

# Server API

# PHP Version

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imagick, imap, intl, ionCube Loader, json, libxml, mbstring, mcrypt, mhash, mssql, mysql, mysqli, mysqlnd, OAuth, odbc, openssl, pcntl, pcre, PDO, pdo_dblib, pdo_mysql, PDO_ODBC, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, pspell, readline, Reflection, session, SimpleXML, soap, sockets, SourceGuardian, SPL, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Guard Loader, zip, zlib.

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 256M
post_max_size - 64M
sql.safe_mode - Off
upload_max_filesize - 64M
mssql.max_links - Unlimited
mssql.max_persistent - Unlimited
mssql.max_procs - Unlimited
mssql.textlimit - Server default
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5

View Replies: View Best Answer
sceva replied on at Permalink Reply
I just noticed it is only the home page with the issue. The sub pages work normally without index.php.
hutman replied on at Permalink Best Answer Reply
Do you by chance have an index.html in your webroot on the server that has the under construction information? If so, you might just have to rename that to "construction.html" or something not index and it will fix itself.
sceva replied on at Permalink Reply
That was the problem. The file was dated 2006, so I am not sure what caused it to start causing an issue now.

Thank you so much!
johnsontvc replied on at Permalink Reply
Great post, a lot of stuff in here i did not know about