Add incoming problem with 5.5

Permalink
This is the first time I've tried to upload an over 7mb file since upgrading to 5.5.1 and there's a problem.

I've uploaded to the incoming folder just fine and when I go to "add incoming" it shows up (it's a PDF so pretty standard file that I know the extension exists in the settings) and let's me click the checkbox. But when I actually click "import files" it gives me this error message:

Upload error
You must select at least one file.

Clearly I have. What's going on here?

AltaPlanning
View Replies: View Best Answer
AltaPlanning replied on at Permalink Reply
AltaPlanning
No one else has experienced this?
BigBobbyD replied on at Permalink Reply
BigBobbyD
This sounds like a problem with your php settings.

There's a setting for max file size, or max post file size, or something like that.

A couple of Google searches and a support request to your host would be worth a try...
AltaPlanning replied on at Permalink Reply
AltaPlanning
I don't think it's the PHP settings because I have the same site using the previous version on the same VPS account within DreamHost, both running PHP version 5.2 CGI.

DreamHost is pretty good getting back about support questions but I'm not sure they'd have specific insight into this C5 feature. But you're right, it's worth a try.
AltaPlanning replied on at Permalink Reply
AltaPlanning
Heard back from my host and worked with php.ini file and it's definitely a C5 problem. I'm continuing to work on it but pretty stuck at this point.

Since no one else seems to be having this problem maybe something happened with my installation and/or it will be fixed in 5.5.2 but I'm definitely leaving the live site on 5.4 for now...
mkly replied on at Permalink Best Answer Reply
mkly
The problem(apparent bug) appears that you are no longer getting the correct error message.

The error is coming from the FileImporter object but there appears to be a bug that overwrites all error messages with that message.

Please file a bug report if you have a chance.

But that said, you probably want to know what gives.

There are two places your import is being rejected/errored out.
1. If you do not have permission to add that file type. Do you have advanced permission turned on? You may want to check permissions. Although an easy test for this would be to attempt to upload a small .pdf file and see. On that note, does this file actually end in .pdf? If not it will fail. Did you check the "Allowed File Types"? is pdf listed there?

2. Any other FileImporter error these are
const    E_PHP_FILE_ERROR_DEFAULT = 0
const    E_PHP_FILE_EXCEEDS_UPLOAD_MAX_FILESIZE = 1
const    E_PHP_FILE_EXCEEDS_HTML_MAX_FILE_SIZE = 2
const    E_PHP_FILE_PARTIAL_UPLOAD = 3
const    E_PHP_NO_FILE = 4
const    E_FILE_INVALID_EXTENSION = 10
const    E_FILE_INVALID = 11
const    E_FILE_UNABLE_TO_STORE = 12

Partial file can happen if the server times out before the import completes.

If you still can't figure out why then you can go in an patch the bug in order to see the correct error message you can go to the file
/concrete/tools/files/importers/incoming.php

or if you updated that installation through the dashboard
/updates/concrete5.5.1/concrete/tools/files/importers/incoming.php

and edit this at line 54
if (count($files) == 0) {
  $error = t('You must select at least one file.');
}

to be something like
if (count($files) == 0) {
  if(!$error) {
    $error = t('You must select at least one file.');
  }
}

Let me know if that works if you try it. At least that way you can see what error you are actually getting which may help you get to the bottom of it.

And again, please report the bug.
AltaPlanning replied on at Permalink Reply
AltaPlanning
I was so excited to try this just to see what error it gave me and go from there but it actually fixed it all together! So thank you so much!

(Just as background notes, I was trying a PDF, a DOC and a GIF, all of which were on my list.)

I'm happy to report this bug. Do you happen to have the link to where on the C5 site to do so? Sometimes it's a little tough for me to find things on here.

And again, so appreciate this answer.
tifoster replied on at Permalink Reply
I'm actually having this same problem. This is the first time I've had to import a large file, so I'm hoping this will also fix mine!
russellfeeed replied on at Permalink Reply
russellfeeed
Use
chmod 777
on the file in files/incoming - this will solve it
Phan087 replied on at Permalink Reply
Hi Guys Im metting the same error ans the file size appear is not the real file size
Thanks