No Editing toolbar...

Permalink
When I open a content block in edit mode it brings it up in html (or some programing language I’m not familiar with). The editing toolbar is completely missing. I’ve used it for years but after this last update it is no longer there. I get this message in place of the toolbar. “Add text content and stylize it using the WYSIWYG editor toolbar. Create links to pages, files and other site assets by using the upper concrete5 toolbar.” How do I get it back?

View Replies:
Guido replied on at Permalink Reply
I have the same issue with a website that I upgraded (in steps) from 5.4.2 to 5.6.3.1.

Console throws an error when the edit pop-up opens:
Uncaught TypeError: Cannot read property 'form' of null
axelhahn replied on at Permalink Reply
axelhahn
Hi Guido,

Open the web developer toolbar in your browser.

I had something similiar during update form 5.6.2.x to 5.6.3.1.
The browser tried to request a language specific file for the tinymce (the editor).

In the console I saw a 404 for
[domain]\updates\concrete5.6.3.1_updater\concrete\js\tiny_mce\plugins\example\langs\de.js

I copied the "en.js" in that dir to "de.js" and it worked.

Axel
Guido replied on at Permalink Reply
Hi Axel,

Thanks, but in my case the (Dutch) language file is being loaded correctly (status 200). Just to make sure it doesn't have anything to do with languages I changed the user's language back to English US and still I'm getting the same error in the console and is the WYSIWYG editor not showing up.
JohntheFish replied on at Permalink Reply
JohntheFish
Guido replied on at Permalink Reply
Thanks, John. Did all that and no further clues... Untill I remembered to check the wysiwyg editor's config in the dashboard. There I found the editor was using a custom configuration. For some reason this configuration wasn't compatible with the updated c5/tinymce. Switching to one of the predefined configs fixed the issue!