Urgent - Migrating to new server, Fatal error: Class 'View' not found

Permalink 5 users found helpful
I've tried this process twice, using the instructions inhttp://www.concrete5.org/documentation/installation/moving_a_site/....

The site is here:


This is the error I've gotten both times:

Fatal error: Class 'View' not found in /home/septics1/public_html/updates/concrete5.6.0.2/concrete/core/libraries/loader.php on line 251

Please help! I've been at this for several hours now.

mkly replied on at Permalink Best Answer Reply
If I remember correctly, in 5.6+ if you don't get your database settings correct you get this somewhat difficult to understand error.

Check your /config/site.php and make sure that it is changed to the new database, database user, and database password. Also, make sure that you have the new database properly set up on the new server.

So, have no fear, nothing is broken, just need to check the database setup.
redkite replied on at Permalink Reply
Thank you. I'm an idiot, I had DB name and DB admin reversed.

mkly replied on at Permalink Reply
Haha, you're not an idiot. I've been there many times. That error is a little rough and I think it's getting cleaned up for a future release. Glad you got it sorted.
rainmaker replied on at Permalink Reply
mkly, you are a LIFE SAVER!!! :) THANK YOU SO MUCH!!!!!
andy17 replied on at Permalink Reply
Thanks a million! Your answer made me realize that I had some problems with my database setup. I was quite clueless because of this nonsense error message.
anda replied on at Permalink Reply
Thanks a lot! I made the same stupid error...

I fixed my config and now it works but only if I explicitely reload the page. If I navigate to the site home page, I still see the error message. If I hit reload then it works.

I have tried with many browsers, cleared my cache on my browsers, cleared the cache in concrete5 without success.

Any ideas?
anda replied on at Permalink Reply
I cleared the session cache in files/tmp and the problem went away... go figure...
madesimplemedia replied on at Permalink Reply
Thanks you're a life saver! :)
chrisemaj7 replied on at Permalink Reply
Thanks for the reply -- two years later ;-)

In my case, I had to change the DB_SERVER from localhost to I'm on a Mac, for what it's worth.
jordanlev replied on at Permalink Reply
This is a terrible horrible no-good error message. I've filed a bug:
...please go to the bug report and "upvote" it so that it gets more attention from the core team.

And thanks @mkly for the explanation. You're my C5 forum hero this week (even though I'm the one that got a karma badge).
jasteele12 replied on at Permalink Reply
I am unable to reproduce this on - I get the following:

Unable to connect to database.
A database error occurred while processing this request.

Doesn't matter whether I switch database, user, host, or just add a few characters to user...
mkly replied on at Permalink Reply
I *think this may already be addressed upstream on github. Don't quote me.

And I have a new badge too if you haven't noticed.
sully210 replied on at Permalink Reply
I just got the same error, my settings are correct and database is set up correctly. I think the problem for me is that I had to use a script(https://github.com/ahukkanen/c5_db_case_sensitivity) to get the lowercase table names from xampp to be camelCase on my linux server. Do you have any ideas? I need to get this site up today.
palmeros replied on at Permalink Reply
Still there on Problem i had was that mysql wasn't started after an upgrade.
Really crappy errormsg tbh.