HELP! I can't edit or save!

Permalink 1 user found helpful
All of a sudden during editing the software stopped working, I can get into edit mode, but I cannot modify anything, it's like none of the buttons work. I can get in to edit a content block, but my editor doesn't come up and I can't type in the block, I have to refresh to get out of it. It won't let me save either, when I try to save or publish it gives me this message::

{"message":null,"title":null,"time":"2014-10-06 15:59:48","redirectURL":"http:\/\/"}

I'm not aware that I've changed any settings, the only thing I did today was add meta tags and a description.

All of my slider pics and info have VANISHED and it won't allow me to add anything.

Please help, I have to have this site operational by tomorrow, we're taking our items into a shop nearby to see if we can sell them there... I'm freaking out!


View Replies:
ryan replied on at Permalink Reply
Is it just one page or all pages?

If it's one page it likely has to do with a recent edit. You can approve a previous version by accessing the version menu from the page in the dashboard sitemap.

If it's all pages, it's likely caused by a javascript error, see if you can open a developer console on your browser and get more info on the error.
TwoMagpies replied on at Permalink Reply
It's on every page, and it won't let me restore any older version, tried that already, I click the restore button and nothing happens. :(

It's almost looking like I just need to re-install Concrete5, I'd rather not do that though... I'm completely at a loss for what to do. Even if I found the error, I have no idea how to fix that, that's why I installed this software, to make it easy. *sadface*

I hope this is just a one off and not some bug with the new version of Concrete5. *le sigh*

Since I can easily fill in all of my website content (since there's not much to my site), should I just re-install?
Jupiter replied on at Permalink Reply
Hello TwoMagpies,

please re-install for better use

TwoMagpies replied on at Permalink Reply
Will do
CMSDeveloper replied on at Permalink Reply
What concrete5 version are you using?
TwoMagpies replied on at Permalink Reply
CMSDeveloper replied on at Permalink Reply
CMSDeveloper is still Beta (with many bugs) and there are no add-ons for it (yet)!
Better use the concrete5 last stable

TwoMagpies replied on at Permalink Reply
I totally understand that, but I didn't want to build my website around outdated software. This recent jump from the previous version of Concrete5 to 5.7 was rather big, new updates will be coming out, new plugins, new themes. I'd rather install 5.7 now and wait for the other developers to catch up, rather than installing the previous version and having to deal with converting over later.
JohntheFish replied on at Permalink Reply
Did any of your meta tags include characters like <, " or ' ?. Maybe such characters could throw things out. I believe all such text is fully escaped by c5, but you never know.

If you can get into the dashboard, you can revert page versions from the sitemap and get back to where you were before the changes you made.

This is not a guaranteed solution, but it would eliminate some possibilities.
TwoMagpies replied on at Permalink Reply
No, none of my meta tags contained any characters like that. I think I'm just going to re-install.
TwoMagpies replied on at Permalink Reply
I just ended up re-installing. Not sure how the site got corrupted, but I will be clicking a lot more carefully.
BHWW replied on at Permalink Reply
Hi i'm also getting this issue when trying to add a page or edit one, i just get this error:

{"message":null,"title":null,"time":"2014-12-04 18:39:16","redirectURL":"http:\/\/localhost:8888\/index.php\/!drafts\/223"}

I'm using any ideas?
Chrouglas replied on at Permalink Reply
I know you solved this (in a way) but I figured I would add some pieces to the puzzle for future reference. I got this error while i was (trying to) create a custom block. It also caused some issue trying to publish a page. I made the error go away by clearing everything out of the block controller. So... maybe you came across a block that was corrupt and maybe you had it in a global area. ??

I don't know... just saying.
DLCCCGreg replied on at Permalink Reply
Hi, I have done this to myself in the old and the new... it is almost always a block with some bad code in it, I usually have it happen adding HTML or PHP blocks, if you can still get the option to delete the block that is suspect and then refresh and publish it will fix itself, if not I have gone straight to the DB and searched for a snippet of what I have added recently and deleted those block content entries with success as well.
I just did it to myself again and searched here to read and that reminded me of the last time it happened, I was too far along to reinstall :-)
rlee1962 replied on at Permalink Reply
Here's what worked for me.
1. In Edit Mode, click on the content in which you'd like to edit.
2. Click "Advanced"
3. Disable ALL "Cache Blocking"
4. Save
5. Refresh browser, clear cache if necessary

That's it, Good Luck!
Durator replied on at Permalink Reply
That did the trick! Forgot about the cache...